17.07.2005 20:39

Canon PIXMA iP1500 and Linux

Canon seems to not be very good in supplying or supporting Linux drivers for their products. Canon PIXMA IP1500 is not an exception. However there is a solution to this.

You can either use turboprint proprietary driver.
Or you can find, that Canon "published" in Japan some kind of Linux driver for some of their pixmas. You can find them on


They can not be used directly for ip1500, but for others like ip3000 etc. you can use them.

For ip1500 I found  this linuxprinting page which says that somebody compiled source available on Japan pages to work with ip1500 - files could be found there - deb and rpm.

To install rpm on FC4 you need to install all dependency by hand - I installed libtasn1, but package also required libpng10.so.0 this I solved by simlinking to libpng.so.2, but also required libtiff.so.4. In FC4 there is only libtiff.so.3.7, I also linked libtiff.so.4 to it even though it's older version. Therefore I had to use rpm --nodeps to install.

After that I had to configure cups. First restart it. The new driver was not reachable trought system-config-printer. The only way how to set up the printer is CUPS administration at http://localhost:631/.
There I had new usb device USB Printer #1with status readback for Canon BJ (Canon iP1500) and also a new category canon, where I found also Canon PIXMA iP1500 Ver.2.50 (en). With this, printer is printing fine.

For Ubuntu users there is also very good howto page.

I’m installing iP1500 for iP1600 printer, but it doesn’t work properly. The indicator is blinking, but no data is printed. Is 1500 compatible or not with iP1600? Any sugestion? I do not know what’s inside ip1600, but I can not get ip1500 working on FC5 too. This howto worked fine on FC4.

covex - 27.04.2006 08:44

Email comment